رفتن به مطلب
بیسیک فور ایکس
  • اطلاعیه ها

    • H@mid.RS

      جذب نیرو   پنجشنبه, 10 فروردین 1396

      درود به دوستان عزیز به چند نفر مدیر برای بخش های php و گرافیک نیازمندیم درصورت تمایل درخواست خود را در پیام خصوصی بفرستید  
    • H@mid.RS

      تغییر نام کاربری   دوشنبه, 28 فروردین 1396

      درود دوستانی که نام کاربری انها با ایمل شان یکی بود تغییر کرد مثلا نام کاربری sss@tmail.com به sss تغییر کرد دوستانی که مشکل ورود دارند @ به بعد را پاک کنند
    • H@mid.RS

      کسب درآمد   پنجشنبه, 31 فروردین 1396

      دوستانی که میخواهند با انجمن خودشون همکاری کنند و از محیط انجمن درآمد کسب کنند به بنده پیام خصوصی بفرستند
    • H@mid.RS

      راه اندازی وبلاگ برای انجمن   دوشنبه, 18 اردیبهشت 1396

      درود به همه دوستان عزیز از این پس کاربران ویژه  - همکاران - و مدیران میتوانند در انجمن برای خود وبلاگ بسازند
  • 0
Ho3ien

سوالات در مورد Manifest

سوال

سلام توی این کد روی 19 باشه تا اندرویید چند پشتیبانی می کنه ؟ 
<uses-sdk android:minSdkVersion="5" android:targetSdkVersion="19"/>

 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

2 پاسخ به این سوال تا کنون داده شده است

Recommended Posts

  • 0

جواب سوالت:

روی همه ورژنها جواب میده

 

در مورد mini sdk

اون 5 رو اگه بزاری فرضا 11 یعنی اندروید3 و حالا یعنی اینکه دیگه روی اندروید3 به پایین جواب نمیده و وقتی برنامه رو به بازار دادی بازار خودبخود اینو میفهمه.مثلا اگر اندروید 2 بیاد اینو نصب کنه پیغام خطای ورژنش بهش میده و دیگه نمیاد اجازه نصب بهش بده.

 

خاب برای چی استفاده میشه؟

شما میای از یک کتابخانه ای استفاده میکنی که روی اندروید پایینتر از 4.4.2 جواب نمیده حالا میای توی مینی sdk اون 5 رو به 19 تغییر میدی.حالا روی اس دی کا 19 به پایین نصب نمیشه.

اگه شما بیای مینی اس دی کا رو روی 5 بزاری و بعدش یه نفر با اندروید 2 میاد برنامه ات رو دان میکنه و بعدش نصب نمیشه دیگه اونجاست که نظر منفی بهت میده با چند رقم فحش نامعلوم

 

در مورد تارگت:

گاهی اوقات نیازه کدهایی که بشه باهاش ران گرفت و خطا نده نیاز به بالا بردن تارگت هست.

 

 

 

اینم مقایسه sdk با ورژن:

Dim version As String
Dim basic4x As Phone
If basic4x.SdkVersion="19" Then
version="4.4.2"
else If basic4x.SdkVersion="18" Then
version="4.3"
else If basic4x.SdkVersion="17" Then
version="4.2.2"
else If basic4x.SdkVersion="16" Then
version="4.1.2"
else If basic4x.SdkVersion="15" Then
version="4.0.3"
else If basic4x.SdkVersion="14" Then
version="4.0"
else If basic4x.SdkVersion="13" Then
version="3.2"
else If basic4x.SdkVersion="12" Then
version="3.1"
else If basic4x.SdkVersion="11" Then
version="3.0"
else If basic4x.SdkVersion="10" Then
version="2.3"
else If basic4x.SdkVersion="9" Then
version="2.3.3"
else If basic4x.SdkVersion="8" Then
version="2.2"
else If basic4x.SdkVersion="7" Then
version="2.1"
else If basic4x.SdkVersion="4" Then
version="1.6"
else If basic4x.SdkVersion="3" Then
version="1.5"
else If basic4x.SdkVersion="21" Then
version="5.0"
else If basic4x.SdkVersion="20" Then
version="4.4.4"
else If basic4x.SdkVersion="22" Then
version="5.1.1"
else If basic4x.SdkVersion="23" Then
version="6.0-6.0.1"
else If basic4x.SdkVersion>"23" Then
version="bozorgtar-az-6"
else If basic4x.SdkVersion<"3" Then
version="kuchektar-az-1.5"
End If

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
  • 0

گرفتم داداش 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

برای ارسال دیدگاه یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید دیدگاهی ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در سایت ما ثبت نام کنید. عضویت خیلی ساده است !

ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید

ورود به حساب کاربری

×